Jump to content

Recommended Posts

I dosed my oscars for white spot yesterday, came home and they are crashng. :“(

Very still breathing rapid, i turned the heater off and am atempting to cool the tank. Shoukd i water change too, what did i do wrong? Only half dosed cause i have a catfish.

Share this post


Link to post
Share on other sites

Def white spot, and aqua master white spot treatment. 50ml to 350litres.

Tank is sitting at 29celcius. I usually have it at 26. Only turned it up yesterday.

Edited by Daharkazangel

Share this post


Link to post
Share on other sites

Ok to get the white spot off the fish u will need to turn ur heater up this will also make the parrasite breed faster however they can only breed when off the fish so that means the most sensitive part is exposed also add some more treatment and some aquarium salt. Treatment normally takes at least 3 days and remove all carbon from the filter

Share this post


Link to post
Share on other sites
that seems like a high dose rate. i would water change the tank as long as the water is not to cold.

According to bottle its half dose. Full dose is 5ml to 20 litres, half dose is 5ml to 40litres.

Im doing a water change but only have tap water temp :/, had to finish at nine didnt i :(

Share this post


Link to post
Share on other sites
Ok I'd still up the temp

No way, ill do it the long way, 26c is fine if I can cool it enough. I think they arw breathing slower, still scary fast. Moving around a bit but still plomping on the bottom here and there.

Share this post


Link to post
Share on other sites

A water change would have added alot of oxygen to the water, whenever you raise temp for adding medication you should add an oxygen supply of some kind.

This can be as simple as moving your filter to create plenty of surface movement.

Hope they are all ok

Share this post


Link to post
Share on other sites
A water change would have added alot of oxygen to the water, whenever you raise temp for adding medication you should add an oxygen supply of some kind.

This can be as simple as moving your filter to create plenty of surface movement.

Hope they are all ok

Thanks, yeah havnt had white spot in over 2 yrs! Guess I forgot about oxygen...rookie mistake -_-

They look MUCH better now. Will update later.

Share this post


Link to post
Share on other sites

Temps still at 27, heaters set at 26 so nearly there. All fish swimming round nicely, even trying to eat bubbles and moving gravel round. Think theyll be fine :D ten years off my heart haha!

Share this post


Link to post
Share on other sites

Final update, fish look excellent. Totally normal and even less white spot. Atempt one at killing my fish, fail. Jokes, but seriously i now know how much i love my fish. Nearly gave me a heart attack! Thanks for the help guys, appreciate it :-)

Share this post


Link to post
Share on other sites

×
×
  • Create New...