Jump to content
Richard_

Fx5 micro bubble problem fixed with ky jelly

Recommended Posts

Hi all

I have 2 fx5 filters that have had issues with micro bubbles

After exhaustive tests I found air leaking into the filter from the top taps where they slide onto the lid. The rubber rings fail to seal air 100% when they're dry so I lubed the orings with a smear of ky jelly and reattached the taps and no bubbles!

Media wasn't the problem, just dry (6 months old filter) orings

I know others have had similar issues so I thought I'd pass this on in case it helps

Share this post


Link to post
Share on other sites

It's my SPARE tube okay :-)

Just letting people know ky worked and maybe use a rubber safe lubricant on the lid's orings (lanolin oil, silicone spray etc...) if they experience micro bubbles, especially after a service

My taps weren't leaking water at all, but they must have been sucking IN the smallest amount of air through where the taps slide and click on

It's hard to find where air is introduced sometimes but my filters are both under 6 months old so these o-rings will need LUBING regularly to avoid further micro bubbles

Edited by Richard_

Share this post


Link to post
Share on other sites

yeah good knowledge if any of my other fx5's have another meltdown, had that one that was problematic the other week replaced with a fx6 so im happy with that at this point in time,

other fx5s seem to come apart/go back together and work just fine and i have one in my collection that is quite a few years old, hasn't needed the ky jelly trick yet haha,

going to be interesting, i wonder if we can substitute the jelly with our own personal saliva, i know the ladies love that sound as you hock it up hahahahaha

Share this post


Link to post
Share on other sites

×
×
  • Create New...