Jump to content

Recommended Posts

Hi All.

So I just got home and my fish room floor is covered in water and the pump is not pumping water back in to the main tank and sump has over flowed,

I have tried changing power sockets and nothing.

jebao 4500 ph, any ideas? Clean it, stuffed???

Cheers Doug

Share this post


Link to post
Share on other sites

I think i had the sump to full, this is my 1st setup with a sump so still learning, It is a 6x2x2 with a 5ft sump, what is recommended for my system which has about 700 litres all up (sump included)

Share this post


Link to post
Share on other sites

I would only run a jebao with a good surge protector. I have had one stop after 18 months for no reason at all and a friend had 3 stop in 12 months for no reason. I have changed to Laguna but if I was to run jebao it would not be without surge protector.

I would recommend a tunze or Laguna but sure other people have good ones to advise

Share this post


Link to post
Share on other sites

Hi Doug,

I hope those electric yellows have settled in ok :)

Just a word of experience guys, as per Murphy's law, sump pumps will stop working unexpectedly at the worst possible time (I had one stop once at mid-night on Xmas Eve) when it is virtually impossible to buy a new one quickly.

I always nowadays keep a spare brand new sump pump in my garage, so when (not if) the pumps stops, I only need to replace it and then replace or repair the old one at my leisure.

Cheers, Doug

Share this post


Link to post
Share on other sites

×
×
  • Create New...