Jump to content
SPA50

No planaria not working?

Recommended Posts

Hey guys and girls, I'm having an issue where I recently acquired planaria and I purchased some No Planaria from Age of Aquariums and I'm half way into my last dose and I'm still seeing tiny white wrigglers/sliders/mongrels! Haha

Should I restart the dosages and if so should I wait a certain amount of time or do a water change or both before doing so?

Cheers

Link to comment
Share on other sites

Been trying to make a call for you most of the morning with our supplier in regards to this as he is a Shrimp enthusiast and this is what he said. He has used it up to double dose and suggested perhaps doing it at a dose and a half. Provide good aeration, like two airstones. Alternatively wait a week and do another coarse is an option too and perhaps a higher dose. When I asked what Shrimp he did it with he mentioned CRS.

Just keep in mind that the above is a bit different from what is suggested on that package and there can be risks involved. Also as you are on day 3 which is towards the end of the coarse we do not know what its current effect is on the Planaria ie is it alive and kicking or suffering the effects or near death.

I er on the side of caution when mentioning things like this simply as I do not want to see any of your shrimp come to any harm.

Link to comment
Share on other sites

Thanks a lot John! Thanks for taking the time to ring around and ask for me!!! I'll see how I go. One has grown since I've started. These are small white worms with a head that looks like the planaria worms. I'll see how I go. Give a water change this weekend and wait till mid week and start again.

Yeah too worried about my Chocs but they seem fine.

You are a legend! Thanks again! :)

Link to comment
Share on other sites



×
×
  • Create New...